Search This Blog

Monday, 14 November 2011

How to configure EBGP on Cisco routers?

How to configure EBGP on Cisco routers?




BASIC CONFIGURATION OF ROUTER-A

A(config)# interface serial 1/0
A(config-if)# ip address 1.0.0.1 255.0.0.0
A(config-if)# clock rate 64000
A(config-if)# no shutdown

A(config-if)# interface ethernet 2/0
A(config-if)# ip address 200.100.50.1 255.255.255.0
A(config-if)# no shutdown

BASIC CONFIGURATION OF ROUTER-B

How to configure EBGP on Cisco routers?




BASIC CONFIGURATION OF ROUTER-A

A(config)# interface serial 1/0
A(config-if)# ip address 1.0.0.1 255.0.0.0
A(config-if)# clock rate 64000
A(config-if)# no shutdown

A(config-if)# interface ethernet 2/0
A(config-if)# ip address 200.100.50.1 255.255.255.0
A(config-if)# no shutdown

BASIC CONFIGURATION OF ROUTER-B
 
B(config)# interface serial 1/1
B(config-if)# ip address 1.0.0.2 255.0.0.0
B(config-if)# no shutdown

B(config-if)# interface ethernet 2/0
B(config-if)# ip address 200.100.100.1 255.0.0.0
B(config-if)# no shutdown

RUNNING RIP ON ROUTER-A

A(config)# router rip
A(config-router)# network 1.0.0.0
A(config-router)# network 200.100.50.0

RUNNING OSPF ON ROUTER-B

B(config)# router ospf 1
B(config-router)# network 1.0.0.00.255.255.255 area0
B(config-router)# network 200.100.100.00.0.0.255 area0


ROUTING TABLE OF ROUTER-A & B
 
RUNNING BGP ON ROUTER-A

A(config)# router bgp 10                                    (10 = Autonomus System)
A(config-router)# neighbor 1.0.0.2 remote-as 20
A(config-router)# network 200.100.50.0


RUNNING BGP ON ROUTER-B

B(config)# router bgp 20                                    (20 = Autonomus System)
B(config-router)# neighbor 1.0.0.1 remote-as 10
B(config-router)# network 200.100.50.0



No comments:

Post a Comment